• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Throttlestop Undervoltage Offset suddenly not working

JackofHearts1216

New Member
Joined
Apr 1, 2020
Messages
2 (0.02/day)
I have an Alienware M17 (First Gen) and became increasingly concerned with it's high operating temperatures. After doing a bit of research, I downloaded and installed throttlestop and then set the CPU and CPU Cache voltage offset by -125mV. When I applied the change, it was immediately noticeable at various areas (Alienware's Command Center Temp trends, Throttlestop's displayed temps, PKG Power, ect). Further, in the FIVR Control menu - it also was displayed in the Offset box.

However, a few days later, I noticed that my computer was noticeably hot. I opened Throttlestop to make sure that everything was enabled properly and noticed that, even though the Adjustable Voltage was unlocked and my Voltage Offsets were turned on... the Voltage Offset displayed in the upper-right box still read 0. Further, in monitoring the real-time Voltage, it did not appear to be working.

I tried various things to try and get it to work like it had. I tried to adjust the Voltage Offset, used the Zero Offset and Reset Voltage buttons. I even uninstalled the application and reinstalled it... and nothing seemed to work.

I've made no changes to my Bios, Windows, or any other system settings in between it working and suddenly not working. My initial download (and first reinstall) was with the current production version of Throttlestop - but I've also tried uninstalling and reinstalling the most recent Beta version. Nothing is working.

Does anyone have any ideas?
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,941 (0.44/day)
Intel released a microcode update last December for all of their CPUs built during the last 5 years. HP and Dell are the first ones to start forcing these updates onto user's computers. Once this update gets installed, software controlled adjustable voltage is gone. Adjustable turbo ratio limits will also be gone. Does TS 8.74 show the word Locked in the FIVR section?



I am just starting to learn about some of the ways that manufacturers are locking down voltage control. This is not a ThrottleStop issue. After this update gets installed, Intel XTU will not work either.

For some Dell computers, this Firmware / BIOS update comes via Windows Update. Seems innocent enough until after it is installed and your laptop suddenly becomes an oven. Some users are having a hell of a time trying to go back to the previous BIOS to get voltage control working again. Post some screenshots of the FIVR window so I can see what microcode version you have installed. Try going back to the previous BIOS and select the Reset to defaults BIOS option if you can get it installed without any errors.
 
Last edited:

JackofHearts1216

New Member
Joined
Apr 1, 2020
Messages
2 (0.02/day)
Yep sure is --- and now that I think about it, I had done a windows update that night and restarted my computer... and now... Locked.

Guess it's time to break my foot off in Dell's backside.

Thanks for the info.
 
Joined
Jun 24, 2015
Messages
1,771 (0.96/day)
Location
Western Canada
System Name Ol' Beastie R3.5
Processor R7 3700X
Motherboard B550M TUF Wifi (0805)
Cooling Dark Rock Pro 4
Memory 32GB Trident Z [3733] (16-19-19-37) (DJR)
Video Card(s) RTX 2060 Super FE (0.919V)
Storage 2.75TB of SSDs
Display(s) GW2765HT
Case TJ08B-E, NF-A14 iPPC-2000 + SW3 120mm
Audio Device(s) DT 770 80Ω [FiiO E10K], Blue Snowball + DS7200B
Power Supply Seasonic SSR-550PX/Cablemod SE
Mouse Endgame XM1
Keyboard various customs
Software Windows 10 2004
If this is the M17, then the latest Plundervolt-patched BIOS should be 2.4.1. Check and see if this is the BIOS you have. Date for 2.4.1 is March 2, 2020.

Current XPS BIOSes have an option near the bottom of the BIOS settings list that enables/disables rollback to an earlier, older BIOS version. Check to see if your BIOS has this option; the box needs to be checked in order to work.

I'm guessing from the BIOS list that you'll want either 2.1.1 or 2.2.1 from July or September of 2019 for undervolting if you can indeed rollback.

Code:
This update addresses the Intel Security Advisories INTEL-SA-00289, INTEL-SA-00307, and INTEL-SA-00317.
INTEL-SA-00289 is the fix for Plundervolt that disabled undervolting, so pre-2.4.1 BIOSes should function normally.

For the sake of posterity, more of these nefarious BIOS updates will be pushed through via Windows Update. The recent Dells also have a BIOS option buried under Security called UEFI capsule firmware updates. Disabling this option prevents the BIOS updates from being pushed through software means, namely Windows Update. Which is a good thing, even in the absence of this whole Plundervolt nonsense, because BIOS updating in software is never a good idea.
 
Last edited:
Top