Tuesday, November 13th 2007

NVIDA ForceWare 169.09 Beta Released

NVIDIA has updated its beta ForceWare driver to version 169.09, which supports just about all GeForce FX, 6, 7 and 8 series graphics cards including the 8800 GT. The only changes in this release are application and compatibility fixes, and this is the recommended driver for Crysis. Download locations are as follows:
  • Windows XP 32-bit – here
  • Windows XP 64-bit – here
  • Windows Vista 32-bit – here
  • Windows Vista 64-bit – here
Add your own comment

7 Comments on NVIDA ForceWare 169.09 Beta Released

#1
PVTCaboose1337
Graphical Hacker
I wonder if this will give umm... advantages to Crysis...
Posted on Reply
#2
erocker
I hope so... The retail version isn't any different from the demo, performance-wise.
Posted on Reply
#3
newconroer
I'm still looking for the 30-40% increase drivers :P
Posted on Reply
#4
EviLZeD
this boosted my fps up by about 8 now everything on high dx9 at 1280-1024 on vista 64 is playable fps varies from 19 to high as 40 but averages about 28
Posted on Reply
#5
newconroer
What did you use before Evil mate?

I want to give these a go, for DX10 very high but..if nhancer and riva don't work, I gotta modify both program's code and that's such a pain in the ass.


EDIT: Nhancer 2.3.2 out..woohoO!
Posted on Reply
#6
EviLZeD
by: newconroer
What did you use before Evil mate?

I want to give these a go, for DX10 very high but..if nhancer and riva don't work, I gotta modify both program's code and that's such a pain in the ass.


EDIT: Nhancer 2.3.2 out..woohoO!
if you mean what drivers i used before 169.04 had about 23fps average on all high dx 9 so it runs better now it also add sli support this is in the demo btw the water reflections are fixed now too
Posted on Reply
#7
newconroer
Yes, everything was going well until I brought up Riva and got the dreaded not supported message. Yet I ignore it, then I goto set my clocks, and unfortunatley...the 3d Performance won't separate from the 2d setting.

Everytime I set say 630 core, then go and check the 2d, it's also 630. I set it to something like 550, then my 3d performance goes back down to 550. And yes, I did tell it to differentiate the 2d/3d settings.

Going to go back to 2.06 beta.
Posted on Reply