Tuesday, May 6th 2008

NVIDIA GeForce 175.16 BETA Drivers Released

NVIDIA has just released the latest 175.16 BETA drivers for all GeForce 6, 7, 8, and 9 video cards.

DOWNLOAD: Windows XP 32-bit / 64-bit | Windows Vista 32-bit /64-bit | Release NotesSource: NVIDIA
Add your own comment

14 Comments on NVIDIA GeForce 175.16 BETA Drivers Released

#1
a111087
nooo they didn't!
btw, why did they decided not to continue Image Sharpening Control on GeForce 8 Series and later GPUs?
* Added support for NVIDIA GeForce 3D Stereo Technology (Windows Vista 32‐bit only).
and ... don't see any hints about performance improvements.
Posted on Reply
#2
..'Ant'..
These drivers work good for me. :)
Posted on Reply
#4
Selene
DV does not work with them for me.
Posted on Reply
#5
Weer
I am very happy with the 175.12 version drivers, unlike all previous versions for my card.

I will only upgrade when I find a certain set to be faulty from now on.
Posted on Reply
#6
Wile E
Power User
Beta, beta, beta! I'm sick of hearing about beta. Give me some goddamned WHQL drivers!!!!!!! I mean it's only been 5 EFFIN MONTHS since a set was released for the 8800GT. Give me an effin break, douchebags!!!
Posted on Reply
#7
Millenia
I second the above notion, I hate how Nvidia always drastically limits the support on their WHQL drivers, at least ATI's got that right. I dislike Nvidia's drivers in general, they just feel meh D:
Posted on Reply
#9
Solaris17
Creator Solaris Utility DVD
by: newconroer
175.63 is out, isn't that newer?
you have a link to all 4 types?
Posted on Reply
#13
newconroer
by: DaedalusHelios
Version 175.63 is dated April 25th, and version 175.16, is dated May 2! :wtf:

Something is fishy....:ohwell:
It's happened before, though not often. If there's a noticeable difference I'll post it.

I know that with 175.63 some games like EQ2, make use of normal AA modes like they should, rather than having to force something insane like 16xS to perform as equivilant of 4x.
Posted on Reply
#14
Haytch
Works fine with my 8800GTX, 9800GTX, 9800Gx2 in XP 32bit with SP3.
Shits itself on reboot with Vista 32bit.
Posted on Reply
Add your own comment