Wednesday, January 21st 2015

TechPowerUp GPU-Z 0.8.1 Released

TechPowerUp released the latest version of GPU-Z, the popular graphics information, monitoring, and diagnostic utility. Version 0.8.1 adds support for new and upcoming GPUs, improves support for existing ones, and fixes a number of bugs. It adds full support for NVIDIA GeForce GTX 960, GTX 980M, and GTX 970M, among others; and AMD Radeon R7 255 and FirePro W7100, among others. It also adds preliminary support for NVIDIA GM200 silicon, and Intel "Broadwell" integrated graphics. Several detection improvements were added, and application stability improved.

DOWNLOAD: TechPowerUp GPU-Z 0.8.1 | GPU-Z 0.8.1 ASUS ROG Themed

The change-log follows.

  • Added full GeForce GTX 960 support
  • Added preliminary NVIDIA GM200 support
  • Fixed NVIDIA GM107 ROP count
  • Added support for NVIDIA GTX 980M, GTX 970M, GTX 660 (960 shaders), GT 705, GT 720, GT 745M, NVS 310, Grid K200
  • Added support for AMD R9 255, FirePro W7100, HD 8370D
  • Added preliminary support for Intel Broadwell Graphics
  • Fixed sensor window having wrong size when using startup option -tab 2
  • Improved memory vendor detection on NVIDIA
  • Added PCI-Express bus usage sensor on NVIDIA
  • Fixed OpenCL detection for Vesuvius GPU
  • Improved detection for future AMD devices
  • Disabled memory vendor detection on future APUs
  • Added millisecond precision for sensor logging when refresh faster than 1 sec
  • Fixed some rare application crashes
Add your own comment

4 Comments on TechPowerUp GPU-Z 0.8.1 Released

#1
Scatler
Added full GeForce GTX 960 support

Oh boi, wizzard sure knows how to tease his audience before nda lift. Cant wait for the reviews to pour in.
Posted on Reply
#2
dj-electric
GTX 960's specs are pretty much "out there". the rest is simple math. no reason not to add it.
Posted on Reply
#3
PM Gravel
Version 0.8.1 is not reporting complete info for my Radeon X1300 video card.
Bus width and Bandwith are not showned.
Posted on Reply
#4
W1zzard
PM Gravel
Version 0.8.1 is not reporting complete info for my Radeon X1300 video card.
Bus width and Bandwith are not showned.
Could you make a new thread in the GPU-Z subforum here, with a screenshot? and if you can, include a screenshot of the last working version.
Posted on Reply