• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Can't get my cpu core clock to stay at 3.4 ghz in ThrottleStop anymore

Patanal

New Member
Joined
Oct 24, 2018
Messages
5 (0.01/day)
Location
Portugal, Porto - Amarante
System Name Obsidian-N850HK
Processor Intel i7-7700HQ
Motherboard Intel® HM175 Chipset
Memory 16 GB 2400MHZ
Video Card(s) Intel Integrated Graphics(viceo out), GTX 1050 Ti
Storage Samsung 960 evo 250gb(bootdrive), Samsung 850 evo 500gb
Display(s) Tn Panel
Case Laptop Clevo
Software Windows 10 Pro
Some days ago I updated throttlestop from 8.60 to 8.70 and for some reason i can't get my cpu to stay at ~3.4 ghz. I tried to downgrade back to 8.60 but got no good results. Am I doing something wrong? I need some help here :)

Ps: Power Mode in windows is in best performance.
FIVR.PNGTS.PNG
 
Joined
Jan 8, 2017
Messages
4,839 (4.09/day)
System Name Good enough
Processor AMD Ryzen R7 1700X - 4.0 Ghz / 1.350V
Motherboard ASRock B450M Pro4
Cooling Scythe Katana 4 - 3x 120mm case fans
Memory 16GB - Corsair Vengeance LPX
Video Card(s) OEM Dell GTX 1080
Storage 1x Samsung 850 EVO 250GB , 1x Samsung 860 EVO 500GB
Display(s) 4K Samsung TV
Case Zalman R1
Power Supply 500W
I used TS a long time ago but I remember that I used to check the multiplier and change it manually.
 

Patanal

New Member
Joined
Oct 24, 2018
Messages
5 (0.01/day)
Location
Portugal, Porto - Amarante
System Name Obsidian-N850HK
Processor Intel i7-7700HQ
Motherboard Intel® HM175 Chipset
Memory 16 GB 2400MHZ
Video Card(s) Intel Integrated Graphics(viceo out), GTX 1050 Ti
Storage Samsung 960 evo 250gb(bootdrive), Samsung 850 evo 500gb
Display(s) Tn Panel
Case Laptop Clevo
Software Windows 10 Pro
I used TS a long time ago but I remember that I used to check the multiplier and change it manually.
Tried it, it's still fluctuating :(
Multiplier.PNG
 

Patanal

New Member
Joined
Oct 24, 2018
Messages
5 (0.01/day)
Location
Portugal, Porto - Amarante
System Name Obsidian-N850HK
Processor Intel i7-7700HQ
Motherboard Intel® HM175 Chipset
Memory 16 GB 2400MHZ
Video Card(s) Intel Integrated Graphics(viceo out), GTX 1050 Ti
Storage Samsung 960 evo 250gb(bootdrive), Samsung 850 evo 500gb
Display(s) Tn Panel
Case Laptop Clevo
Software Windows 10 Pro
Tried that, still going up and down like a balerina :(
Speedstep off.PNG
 
Joined
Jul 5, 2013
Messages
8,941 (3.63/day)
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Ok, I'm stumped. On my system the multi is locked.

What happens when you go back to 8.60? Have you tried it?
 
Joined
Jun 15, 2016
Messages
1,041 (0.75/day)
Location
Pristina
System Name My PC
Processor 4670K@4.4GHz
Motherboard Gryphon Z87
Cooling CM 212
Memory 2x8GB+2x4GB @2400GHz
Video Card(s) XFX Radeon RX 580 GTS Black Edition 1425MHz OC+, 8GB
Storage Intel 530 SSD 480GB + Intel 510 SSD 120GB + 2x500GB hdd raid 1
Display(s) HP envy 32 1440p
Case CM Mastercase 5
Audio Device(s) Sbz ZXR
Power Supply Antec 620W
Mouse G502
Keyboard G910
Software Win 10 pro
Try to increase icc to 35A and offset voltage to 0.
 
Joined
Jul 5, 2013
Messages
8,941 (3.63/day)
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,593 (0.37/day)
If you want a steady multiplier then you need to turn off all of the C states including C1E, C3, C6 and C7. Most laptops do not let you toggle the C States on and off in the bios but there is a registry mod you can use if you want to see what your laptop is like with the C States disabled.
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Intelppm
Go to the above registry key and set Start to 4 to disable the C2/C3/C6/C7 low power core and package C states. Default value for this is 3. You will need to reboot to see any change.

After doing this, ThrottleStop will show you that your CPU is consuming more power and running hotter. You can go back to the original value anytime you like.

After you disable the C states, the 7700HQ will not have access to the 35, 36, 37 or 38 multiplier so in any single threaded task, your CPU will run slower.

Your screenshot shows that you have Speed Shift enabled (SST in green). Windows 10 uses this on many newer CPUs. When Speed Shift is enabled, the older SpeedStep (Set Multiplier) will not do anything. You need to set the Speed Shift EPP value to 0 for maximum performance. You can also use the Speed Shift Max value to cap the maximum multiplier.

Edit - The result. A nice steady multiplier across all threads even when the CPU is idle. Idle temps are up 15°C even with the fan spinning a little faster.



Compare that to having C states enabled. Now the CPU can access its higher turbo multipliers, it consumes less power and runs cooler. For a laptop, I like C states on. There are some unique situations like music production where disabling the C states to minimize latency can be a good thing.

 
Last edited:
Joined
Jul 5, 2013
Messages
8,941 (3.63/day)
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
@unclewebb Just learned a few things. Nice. Thank You!
 

Patanal

New Member
Joined
Oct 24, 2018
Messages
5 (0.01/day)
Location
Portugal, Porto - Amarante
System Name Obsidian-N850HK
Processor Intel i7-7700HQ
Motherboard Intel® HM175 Chipset
Memory 16 GB 2400MHZ
Video Card(s) Intel Integrated Graphics(viceo out), GTX 1050 Ti
Storage Samsung 960 evo 250gb(bootdrive), Samsung 850 evo 500gb
Display(s) Tn Panel
Case Laptop Clevo
Software Windows 10 Pro
If you want a steady multiplier then you need to turn off all of the C states including C1E, C3, C6 and C7. Most laptops do not let you toggle the C States on and off in the bios but there is a registry mod you can use if you want to see what your laptop is like with the C States disabled.
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Intelppm
Go to the above registry key and set Start to 4 to disable the C2/C3/C6/C7 low power core and package C states. Default value for this is 3. You will need to reboot to see any change.

After doing this, ThrottleStop will show you that your CPU is consuming more power and running hotter. You can go back to the original value anytime you like.

After you disable the C states, the 7700HQ will not have access to the 35, 36, 37 or 38 multiplier so in any single threaded task, your CPU will run slower.

Your screenshot shows that you have Speed Shift enabled (SST in green). Windows 10 uses this on many newer CPUs. When Speed Shift is enabled, the older SpeedStep (Set Multiplier) will not do anything. You need to set the Speed Shift EPP value to 0 for maximum performance. You can also use the Speed Shift Max value to cap the maximum multiplier.

Edit - The result. A nice steady multiplier across all threads even when the CPU is idle. Idle temps are up 15°C even with the fan spinning a little faster.



Compare that to having C states enabled. Now the CPU can access its higher turbo multipliers, it consumes less power and runs cooler. For a laptop, I like C states on. There are some unique situations like music production where disabling the C states to minimize latency can be a good thing.

Man I tried everything but still isn't working. I did regedit "Start" to 4 and set icc to 35 A all of these I did in order not in the same time. Now I have both settings on and still nothing
Reg Edit to 4 and icc to 35A.PNG
 

unclewebb

RealTemp Author
Joined
Jun 1, 2008
Messages
1,593 (0.37/day)
In your screenshot above now you have Speed Shift disabled. SST is no longer green on the main screen. When Speed Shift is disabled, the Speed Shift - EPP setting that you have checked and set to 0 does not do anything. You have to decide whether you will be using Speed Shift or not using Speed Shift. Enable it in the TPL window.

If you do not plan to use Speed Shift, then you need to enable SpeedStep. The Set Multiplier function depends on this being enabled.

Does the C State window show that all of your C states are disabled? Are you using the Windows high performance power profile with the minimum processor state set to 100%? Your Windows power plan settings might be interfering with your quest for a steady multiplier.
 
Last edited:

Patanal

New Member
Joined
Oct 24, 2018
Messages
5 (0.01/day)
Location
Portugal, Porto - Amarante
System Name Obsidian-N850HK
Processor Intel i7-7700HQ
Motherboard Intel® HM175 Chipset
Memory 16 GB 2400MHZ
Video Card(s) Intel Integrated Graphics(viceo out), GTX 1050 Ti
Storage Samsung 960 evo 250gb(bootdrive), Samsung 850 evo 500gb
Display(s) Tn Panel
Case Laptop Clevo
Software Windows 10 Pro
I think I got it. But I'm not using throttlestop anymore. Yes I had 100% min and 100% max in power settings.
In your screenshot above now you have Speed Shift disabled. SST is no longer green on the main screen. When Speed Shift is disabled, the Speed Shift - EPP setting that you have checked and set to 0 does not do anything. You have to decide whether you will be using Speed Shift or not using Speed Shift. Enable it in the TPL window.

If you do not plan to use Speed Shift, then you need to enable SpeedStep. The Set Multiplier function depends on this being enabled.

Does the C State window show that all of your C states are disabled? Are you using the Windows high performance power profile with the minimum processor state set to 100%? Your Windows power plan settings might be interfering with your quest for a steady multiplier.
 

Attachments

Top