• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

is it normal to have high cpu usage from radeon software all the time? my gpu is rx 6800 and cpu is 5600x

Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
it uses 10% of my cpu at all times... when gaming, when not gaming, etc...

 

Rei

Joined
Aug 1, 2020
Messages
656 (2.58/day)
Location
Guam
System Name 1 Desktop/2 Laptops/1 Netbook
Processor AMD Athon X2 64/Intel Pentium 997/Intel Pentium 4/Intel Atom
Motherboard EpoX ATX motherboard/Samsung/Toshiba/Lenovo
Cooling Stock
Memory 4 GB/4 GB/2 GB/2 GB
Video Card(s) Asus GeForce GTX 780 Ti/Intel HD Graphics/GeForce 4MX/Intel GMA
Storage 6+ TB Total
Display(s) HP Pavilion 14 Inch 1024x768@60Hz 4:3 Aspect Ratio CRT Monitor
Case None
Audio Device(s) Various
Power Supply Seasonic 500 Watt & VenomRX 500 Watt
Mouse Wayes Iron Man Wireless Mouse
Keyboard Rexus VR2 Wireless Keyboard
Software Win10 & WinXP SP3
Benchmark Scores It sucks...
Probably related to this PSA thread here:


That power usage is really high though for a sub-15% CPU usage. Mine usually starts at over 40% or 50% when power usage is very high.
 
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
Probably related to this PSA thread here:


That power usage is really high though for a sub-15% CPU usage. Mine usually starts at over 40% or 50% when power usage is very high.

hopefully a bios update to mobo, and fresh drivers/clean install next month or in feb fixes it for me.
 
  • Like
Reactions: Rei
Joined
Dec 18, 2020
Messages
22 (0.19/day)
Location
United Kingdong
System Name Sufficient Gamer
Processor AMD Ryzen 1600AF CPU
Motherboard MSI something
Cooling Yes
Memory 16 Gigawatts
Video Card(s) RDNA 5600-ExTea
Storage Some hard drives and some flacid drives
Display(s) Dellllllllllllll
Case Metal Box
Audio Device(s) Ears
Power Supply The grid
Mouse Squeak squeak
Software Windbloats 10
No, not normal, is this idle at the desktop or doing other non gaming tasks like browsing? Firstly ddu your drivers if you haven't already, clean install the latest whql ones, see if that fixes it if not then you'll have to look at what else could be causing it, that process is eating 0% of my CPU just sitting at the desktop and using opera. I wouldn't wait a month to do a driver refresh.

Theres a few ideas here also and by doing a quick duckduckgo search (I don't use google :p) such asusing the factory reset option with in the radeon settings, changing relive directory etc

 
Last edited:
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
No, not normal, is this idle at the desktop or doing other non gaming tasks like browsing? Firstly ddu your drivers if you haven't already, clean install the latest whql ones, see if that fixes it if not then you'll have to look at what else could be causing it, that process is eating 0% of my CPU just sitting at the desktop and using opera. I wouldn't wait a month to do a driver refresh.

Theres a few ideas here also and by doing a quick duckduckgo search (I don't use google :p) such asusing the factory reset option with in the radeon settings,

already tried that. and i tried it in safe mode with ddu, got rid of it all. and then reinstalled everything, and everytime i tried installing fresh amd drivers it would get stuck... so yeah i guess i will just doa clean install tonight. it doesn't take me very long as i only game... and thats all on backup drives so meh.
 
Joined
Dec 18, 2020
Messages
22 (0.19/day)
Location
United Kingdong
System Name Sufficient Gamer
Processor AMD Ryzen 1600AF CPU
Motherboard MSI something
Cooling Yes
Memory 16 Gigawatts
Video Card(s) RDNA 5600-ExTea
Storage Some hard drives and some flacid drives
Display(s) Dellllllllllllll
Case Metal Box
Audio Device(s) Ears
Power Supply The grid
Mouse Squeak squeak
Software Windbloats 10
Do you use relive?
 
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
Joined
Nov 13, 2007
Messages
8,391 (1.71/day)
Location
Austin Texas
System Name Chernobyl
Processor 10850K @ 5.1
Motherboard MSI 490-A PRO
Cooling 360mm AIO
Memory 32 GB 4100 Mhz DDR4 18-18-18-38-440 trfc - 2T
Video Card(s) MSI Ventus RTX 3080
Storage 3x1TB SSDs, 2TB SSD
Display(s) LG 49NANO85 - 49" 4K 120HZ NanoIPS
Case Zalman X3
Audio Device(s) Bose Solo
Power Supply Corsair SF750
Mouse Logitech GPro Wired
Keyboard tecware phantom
Software Windows 10 64 Bit
wipe and reinstall it didn't work? definitely not normal
 
Joined
Dec 18, 2020
Messages
22 (0.19/day)
Location
United Kingdong
System Name Sufficient Gamer
Processor AMD Ryzen 1600AF CPU
Motherboard MSI something
Cooling Yes
Memory 16 Gigawatts
Video Card(s) RDNA 5600-ExTea
Storage Some hard drives and some flacid drives
Display(s) Dellllllllllllll
Case Metal Box
Audio Device(s) Ears
Power Supply The grid
Mouse Squeak squeak
Software Windbloats 10
Probably related to this PSA thread here:


That power usage is really high though for a sub-15% CPU usage. Mine usually starts at over 40% or 50% when power usage is very high.
No offense but how can it be related to that when that's regarding an Nvidia GPU system that also has AMD drivers installed, he doesn't have an Nvidia GPU installed.

Have you got the latest drivers or the WHQL ones? I prefer to stick to WHQL (usually underneath the latest released ones on the download page) or the Pro drivers, seems less headaches though could likely just a placebo affect? :confused::laugh:

Also the other usual suspects, latest chipset and motherboard drivers should be up to date, and a reinstall of those (especially the chipset ones, there are likely newer ones available from AMD than the ones on your motherboards download page) also worth a shot IMO
 
  • Like
Reactions: Rei
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
wipe and reinstall it didn't work? definitely not normal

i think it was my fault actually. i tried using to some hotfix 12.2 driver i got off guru3d... and it was only for 6800 xt and 6900 xt cards... not non-6800... i think that's what messed it up lol but at the time i thought it was for all 3 new cards... (thats when my problems started)

honestly just going to do a clean install tonight, it will be fine after that meh. it will only take me an hr
 
  • Like
Reactions: Rei
Joined
Dec 18, 2020
Messages
22 (0.19/day)
Location
United Kingdong
System Name Sufficient Gamer
Processor AMD Ryzen 1600AF CPU
Motherboard MSI something
Cooling Yes
Memory 16 Gigawatts
Video Card(s) RDNA 5600-ExTea
Storage Some hard drives and some flacid drives
Display(s) Dellllllllllllll
Case Metal Box
Audio Device(s) Ears
Power Supply The grid
Mouse Squeak squeak
Software Windbloats 10
i think it was my fault actually. i tried using to some hotfix 12.2 driver i got off guru3d... and it was only for 6800 xt and 6900 xt cards... not non-6800... i think that's what messed it up lol but at the time i thought it was for all 3 new cards... (thats when my problems started)

honestly just going to do a clean install tonight, it will be fine after that meh. it will only take me an hr
They havent released any modern drivers for years, infact back when it was ATI control centre, not sure how you even installed them on a modern GPU and system if what you're saying is correct
 
  • Like
Reactions: Rei
Joined
Dec 16, 2017
Messages
1,607 (1.32/day)
Location
Buenos Aires, Argentina
System Name System V
Processor AMD Ryzen 5 3600
Motherboard Asus Prime X570-P
Cooling AMD Wraith Stealth // a bunch of 120 mm Xigmatek 1500 RPM fans (2 ins, 3 outs)
Memory 2x8GB Ballistix Sport LT 3200 MHz (BLS8G4D32AESCK.M8FE) (CL16-18-18-36)
Video Card(s) Gigabyte AORUS Radeon RX 580 8 GB
Storage SHFS37A240G / DT01ACA200 / WD20EZRX / MKNSSDTR256GB-3DL / LG BH16NS40 / ST10000VN0008
Display(s) LG 22MP55 IPS Display
Case NZXT Source 210
Audio Device(s) Logitech G430 Headset
Power Supply Corsair CX650M
Mouse Microsoft Trackball Optical 1.0
Keyboard HP Vectra VE keyboard (Part # D4950-63004)
Software Whatever build of Windows 10 is being served in Dev channel at the time.
Benchmark Scores Corona 1.3: 3120620 r/s Cinebench R20: 3355 FireStrike: 12490 TimeSpy: 4624
They havent released any modern drivers for years, infact back when it was ATI control centre, not sure how you even installed them on a modern GPU and system if what you're saying is correct
The still do, they just never bothered changing the category name.
20201229-191017.png
 
Joined
Dec 18, 2020
Messages
22 (0.19/day)
Location
United Kingdong
System Name Sufficient Gamer
Processor AMD Ryzen 1600AF CPU
Motherboard MSI something
Cooling Yes
Memory 16 Gigawatts
Video Card(s) RDNA 5600-ExTea
Storage Some hard drives and some flacid drives
Display(s) Dellllllllllllll
Case Metal Box
Audio Device(s) Ears
Power Supply The grid
Mouse Squeak squeak
Software Windbloats 10
The still do, they just never bothered changing the category name.
View attachment 181518
Good find, I take it these are stock AMD drivers or modded? personally there's no reason to download them from anywhere but AMD these days, especially with new GPU's and monthly updates etc I won't even download the "official" Powercolor one for my Powercolor 5600 XT.
 
  • Like
Reactions: Rei
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)

these are the ones that messed up my system... again my fault, I thought it included rx 6800 NON-XT but nope lol so yeah... lesson learned, pay attention
 
Joined
Sep 19, 2020
Messages
261 (1.27/day)
System Name The Big Burrito
Processor R7 5800x
Motherboard MSI B550 Unify
Cooling Noctua NH-D15 Chromax
Memory 64GB 3600Mhz C18
Video Card(s) RX 6800
Storage SSDs and spinning rust
Display(s) 32" 165Hz 1440p
Case Phanteks P600s
Audio Device(s) Schiit DAC, various amps and headphones
Power Supply Seasonic 850w TX-Prime
Mouse Razer stupid RGB wireless
Keyboard Corsair K70 Lux - MX Blue Clickity-Click
Good find, I take it these are stock AMD drivers or modded? personally there's no reason to download them from anywhere but AMD these days, especially with new GPU's and monthly updates etc I won't even download the "official" Powercolor one for my Powercolor 5600 XT.

They're stock drivers. The only difference is that the 20.12.2 are only for the 6800xt ad 6900xt. Direct from AMD this version doesn't show available for download unless you use either the auto-detect, or choose the 6800xt or 6900xt. If you select 6800, the latest available version is 20.12.1
 
  • Like
Reactions: Rei
Joined
Dec 16, 2017
Messages
1,607 (1.32/day)
Location
Buenos Aires, Argentina
System Name System V
Processor AMD Ryzen 5 3600
Motherboard Asus Prime X570-P
Cooling AMD Wraith Stealth // a bunch of 120 mm Xigmatek 1500 RPM fans (2 ins, 3 outs)
Memory 2x8GB Ballistix Sport LT 3200 MHz (BLS8G4D32AESCK.M8FE) (CL16-18-18-36)
Video Card(s) Gigabyte AORUS Radeon RX 580 8 GB
Storage SHFS37A240G / DT01ACA200 / WD20EZRX / MKNSSDTR256GB-3DL / LG BH16NS40 / ST10000VN0008
Display(s) LG 22MP55 IPS Display
Case NZXT Source 210
Audio Device(s) Logitech G430 Headset
Power Supply Corsair CX650M
Mouse Microsoft Trackball Optical 1.0
Keyboard HP Vectra VE keyboard (Part # D4950-63004)
Software Whatever build of Windows 10 is being served in Dev channel at the time.
Benchmark Scores Corona 1.3: 3120620 r/s Cinebench R20: 3355 FireStrike: 12490 TimeSpy: 4624
Good find, I take it these are stock AMD drivers or modded? personally there's no reason to download them from anywhere but AMD these days, especially with new GPU's and monthly updates etc I won't even download the "official" Powercolor one for my Powercolor 5600 XT.
Don't really know, but I suppose they are stock, otherwise it would say. The only places where I ever downloaded the Radeon drivers from are either TPU or AMD themselves. And these days, with the update feature integrated into Radeon Software itself, I just read the changelog here and then get to the program and tell it to start downloading...
1609280939755.png


I haven't bothered ever trying the Gigabyte version of Radeon drivers for my RX 580, which by the way haven't been updated since 2018...

By the way, @lynx29 you should consider just using the update feature in Radeon Software, it will select the correct driver version for your card in these rare cases. You can set it to either just WHQL or Betas and WHQL. The drivers are usually downloaded to C:\AMD, if you want to keep copies of them.
1609281263271.png
 
Last edited:

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
16,983 (3.37/day)
Location
UK\US
Processor 2500k \ AMD 3900X+NH-D15
Motherboard ASRock Z68 \ ASRock AM4 X570 Pro 4
Memory Samsung low profile 2x8GB \ Patriot 2x16GB PVS432G320C6K
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage 2xIntel 80Gb (SATA2) Crucial MX500 \ Samsung 860 1TB +Samsung Evo 250GB+500GB Sabrent 1TB Rocket
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( VE2000BWS ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000, Blue Yeti
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse Steelseries Sensei wireless \ Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
Yeah some things going on for sure, never seen it any were that high even more so at idle. at idle it's 0.02% lmao. Maybe it's a bug in the drivers so maybe try another version ?.

Untitled.jpg
 
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
Yeah some things going on for sure, never seen it any were that high even more so at idle. at idle it's 0.02% lmao. Maybe it's a bug in the drivers so maybe try another version ?.

View attachment 181523

ya it was installing the wrong driver and i had an OC on the gpu at the time, it prob had something to do with that, and once i uninstalled those drivers... and went back to old drivers, games were laggy etc more than usual... so just gonna do a clean install, won't take me long and will be rock solid after that im sure lol
 
Joined
Dec 18, 2020
Messages
22 (0.19/day)
Location
United Kingdong
System Name Sufficient Gamer
Processor AMD Ryzen 1600AF CPU
Motherboard MSI something
Cooling Yes
Memory 16 Gigawatts
Video Card(s) RDNA 5600-ExTea
Storage Some hard drives and some flacid drives
Display(s) Dellllllllllllll
Case Metal Box
Audio Device(s) Ears
Power Supply The grid
Mouse Squeak squeak
Software Windbloats 10
Make sure windows isn't allowed to install driver updates, reset afterburner if you have an OC profile or whatever, use DDU, install latest drivers using factory clean install option, reboot and (hopefully) win :toast:
 
  • Like
Reactions: Rei
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
Make sure windows isn't allowed to install driver updates, reset afterburner if you have an OC profile or whatever, use DDU, install latest drivers using factory clean install option, reboot and (hopefully) win :toast:

I'm just going to do a clean install lol i have all my steam games backed up, so reinstalling them doesn't take that long honestly.
 
  • Like
Reactions: Rei

Rei

Joined
Aug 1, 2020
Messages
656 (2.58/day)
Location
Guam
System Name 1 Desktop/2 Laptops/1 Netbook
Processor AMD Athon X2 64/Intel Pentium 997/Intel Pentium 4/Intel Atom
Motherboard EpoX ATX motherboard/Samsung/Toshiba/Lenovo
Cooling Stock
Memory 4 GB/4 GB/2 GB/2 GB
Video Card(s) Asus GeForce GTX 780 Ti/Intel HD Graphics/GeForce 4MX/Intel GMA
Storage 6+ TB Total
Display(s) HP Pavilion 14 Inch 1024x768@60Hz 4:3 Aspect Ratio CRT Monitor
Case None
Audio Device(s) Various
Power Supply Seasonic 500 Watt & VenomRX 500 Watt
Mouse Wayes Iron Man Wireless Mouse
Keyboard Rexus VR2 Wireless Keyboard
Software Win10 & WinXP SP3
Benchmark Scores It sucks...
No offense but how can it be related to that when that's regarding an Nvidia GPU system that also has AMD drivers installed, he doesn't have an Nvidia GPU installed.
Whoops... My bad. Forgot that AMD driver need to be uninstalled when high CPU usage happens. That thread came to mind when I think of Lynx29's issue.

Well, since I never had a Radeon card before, I don't have any experience with it to be able to give this thread any advise. I will however, continue to monitor this thread to learn the issue & steps it takes to fix it.
 

fxp555

New Member
Joined
Dec 30, 2020
Messages
1 (0.01/day)
I'm just going to do a clean install lol i have all my steam games backed up, so reinstalling them doesn't take that long honestly.
Did you install a BIOS Update? I experience the same issue after upgrading to the latest ASUS Bios...
 
Joined
Oct 17, 2014
Messages
6,100 (2.57/day)
Location
USA
System Name Paladius Tacet
Processor Ryzen 5600x
Motherboard MSI X570 Tomahawk
Cooling Arctic Freezer 34 DUO (custom aggressive fan curve)
Memory G.Skill 2x16 3600 14-14-14-34 Dual Rank
Video Card(s) Navi 6800 + Rage Mode + OC
Display(s) Acer Nitro XF243Y 23.8" 0.5ms IPS 165hz 1080p
Case Corsair 110Q Silent + NZXT Aer-P exhaust fan
Power Supply EVGA 700w Gold
Mouse Razer Naga X (2021 Edition)
Did you install a BIOS Update? I experience the same issue after upgrading to the latest ASUS Bios...

I did, on November 16th, I never checked task manager until mid December though, so I have no idea if it has been doing it since that update or not.

However, I did just finish my clean install of Win 10 - full re-do - and everything is perfect, no high cpu usage, everything is great now. lol

I'm going to laugh if tomorrow AMD releases new drivers, pretty much how my luck goes.
 

ljbitzki

New Member
Joined
Mar 3, 2021
Messages
1 (0.03/day)
I've found a solution (that works for me). Using the ProcessMonitor from Microsoft SysInternals with autoscroll enable, I can see the "Radeon Software: Host Application" process in a loop trying to find some directories, all of them from uninstalled games that still have an empty folder (thanks, Steam :(). In my case are in the same base path "D:\Program Files (x86)\Steam\steamapps\common", the folders "Destiny 2", "Keep Talking and Nobody Explodes" and "RESIDENT EVIL REVELATIONS 2". Since all this three folders are empty, when I finish delete the last one, the Radeon Software become 0% of CPU usage.
Again, this work for me and the folders may vary but I think you can try that. :)
 
Top