• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

[SOLVED] Install my printer just fine in Ubuntu but can't get it to print

HTC

Joined
Apr 1, 2008
Messages
4,061 (0.91/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Here's what the terminal reports:

Screenshot from 2020-05-13 19-51-48.png

The 1st time after doing what you asked with the terminal when i tried to print the document, it got held for several minutes and the restarted printing again on it's own but got held again: took quite a while but it eventually finished the page but, upon examination, it printed the start of the document each time after the hold up. If i knew how to use the scanner under Ubuntu, i'd post the document (simple scan doesn't work: that was the 1st thing i tried).
I've since attempted to print it again but i'm having the same results :(
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,688 (3.83/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
Got held, same as before :(

View attachment 155073

Anything "fun" in that pic?

EDIT

I entered the command in the terminal BEFORE starting to print.
Yeah actually, do you see that line that says "usblp0: removed" and the line right before says that device is a USB Bidirectional printer. I guess it's possible that the USB connection is getting interrupted while the device is operating. Does the printer have a wireless printing mode? If it does, I suggest trying it out. I've had far fewer issues with wireless printing than running over USB. It sounds like the USB connection is unstable.
 

HTC

Joined
Apr 1, 2008
Messages
4,061 (0.91/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Yeah actually, do you see that line that says "usblp0: removed" and the line right before says that device is a USB Bidirectional printer. I guess it's possible that the USB connection is getting interrupted while the device is operating. Does the printer have a wireless printing mode? If it does, I suggest trying it out. I've had far fewer issues with wireless printing than running over USB.
It does yes, but i dunno how to install it that way.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,688 (3.83/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
It does yes, but i dunno how to install it that way.
With printers that don't have a UI, there is typically a process for connecting it to the WiFi. Hopefully it doesn't require an initially wired connection (it wouldn't be the first time I've seen that.) WPS is the easiest and fastest way to do it if you have a router and printer that support it. I tend to do this with my own devices.
 

HTC

Joined
Apr 1, 2008
Messages
4,061 (0.91/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
With printers that don't have a UI, there is typically a process for connecting it to the WiFi. Hopefully it doesn't require an initially wired connection (it wouldn't be the first time I've seen that.) WPS is the easiest and fastest way to do it if you have a router and printer that support it. I tend to do this with my own devices.
New problem:

Screenshot from 2020-05-13 20-26-56.png


My sister's PC used MY WI-FI just fine ... but i can't use it ... no idea why :(

No Wi-fi entry under "network".
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,688 (3.83/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
New problem:

View attachment 155078

My sister's PC used MY WI-FI just fine ... but i can't use it ... no idea why :(

No Wi-fi entry under "network".
If you're using a wired connection on the computer, you don't need to set up WiFi there, you need to set it up on the printer. You don't need to use WiFi to do wireless printing, you just need the printer to be connected to the network, much like you attach a NAS to the network to gain access to things like Samba or NFS shares.

There may be a driver for the Intel WiFi adapter on the board in your specs that you need to install, but that's unrelated IMHO.
 

HTC

Joined
Apr 1, 2008
Messages
4,061 (0.91/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
If you're using a wired connection on the computer, you don't need to set up WiFi there, you need to set it up on the printer. You don't need to use WiFi to do wireless printing, you just need the printer to be connected to the network, much like you attach a NAS to the network to gain access to things like Samba or NFS shares.

There may be a driver for the Intel WiFi adapter on the board in your specs that you need to install, but that's unrelated IMHO.
My connection is wired, yes.

I think i figured out why i don't have wi-fi on my PC despite my board supporting it: due to having wired connection, i never bothered to install the antennas that came with the board ... :slap:

Unfortunately, dunno how to do that :(
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,688 (3.83/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
My connection is wired, yes.

I think i figured out why i don't have wi-fi on my PC despite my board supporting it: due to having wired connection, i never bothered to install the antennas that came with the board ... :slap:

Unfortunately, dunno how to do that :(
I'd find the documentation that came with the printer to help you setup the WiFi on the printer. You don't need to fiddle with the WiFi on the tower. As I said, only the printer needs to connect to WiFi if the tower is already on the network.

I don't want to digress, but if the WiFi device not showing up (which you shouldn't worry about since it doesn't appear that you need it,) there is a probably an additional driver you need to install for that. It'd probably show up in "Additional Drivers" in the "Software & Updates" control panel. I thought Intel WiFi was supported OOTB, but apparently not.
 

HTC

Joined
Apr 1, 2008
Messages
4,061 (0.91/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Figured out what the problem was: it was the USB cable ...

As soon as i tried another cable, the printer printed normally, but i couldn't report this earlier because ... i lost my NET since early Sunday ...

The problem is now solved.
 
Top