• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Realtek DCH Modded Audio Driver for Windows 10

Joined
Dec 13, 2014
Messages
291 (0.13/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education v1809
WARNING: There is also an update for Nahimic on the Microsoft Store to version 1.5.4.0, but it is very likely that once installed, your enhancement will stop working.

actually Alan, version 1.5.7.0 of the Nahimic app was recently available from the MS store instead of 1.5.4.0.
in any case, disable MS store auto updates to prevent it from updating the Nahimic app to 1.5.4.0 or greater

edit - so you need to edit/update the description about this recent version of the Nahimic app from MS store as it may no longer offer the 1.5.4.0 version for some users
 
Joined
May 20, 2018
Messages
140 (0.14/day)
Location
Germany
System Name Metal-Tom-PC
Processor AMD Ryzen 5 2600x
Motherboard ASUS ROG Crosshair VI Extreme
Cooling Boxed
Memory Mushkin DDR4 16 GB
Video Card(s) ASUS RX560 4GB
Storage 1x M2-SSD @256GB/1x Intenso SATA-SSD @120GB/1x Intenso SATA-SSD @240GB/2x WD10EZRX @1TB/1,5 TB HDD
Display(s) 1x Samsung LE40F86BDX (TV)/1x Samsung SyncMaster T240
Case Thermaltake Kandalf LCS
Audio Device(s) Realtek ALC1220A
Power Supply SeaSonic Focus Plus Gold 80+ 750W
Mouse Logitech M210
Keyboard Logitech K260
Software Win 10 Pro x64 v20H2
Joined
Dec 8, 2020
Messages
199 (2.43/day)
Hmm, I will do some code pulling tomorrow, however you want the .dll's and code from the .inf. If you separate the extra code into a separate .inf along with the .dlls, you can convert it into an extension.

I have a tendency to reverse engineer, so its immediate to play 'spot the difference' with code and files.
 
Joined
May 20, 2018
Messages
140 (0.14/day)
Location
Germany
System Name Metal-Tom-PC
Processor AMD Ryzen 5 2600x
Motherboard ASUS ROG Crosshair VI Extreme
Cooling Boxed
Memory Mushkin DDR4 16 GB
Video Card(s) ASUS RX560 4GB
Storage 1x M2-SSD @256GB/1x Intenso SATA-SSD @120GB/1x Intenso SATA-SSD @240GB/2x WD10EZRX @1TB/1,5 TB HDD
Display(s) 1x Samsung LE40F86BDX (TV)/1x Samsung SyncMaster T240
Case Thermaltake Kandalf LCS
Audio Device(s) Realtek ALC1220A
Power Supply SeaSonic Focus Plus Gold 80+ 750W
Mouse Logitech M210
Keyboard Logitech K260
Software Win 10 Pro x64 v20H2
Hmm, I will do some code pulling tomorrow, however you want the .dll's and code from the .inf. If you separate the extra code into a separate .inf along with the .dlls, you can convert it into an extension.

I have a tendency to reverse engineer, so its immediate to play 'spot the difference' with code and files.

I don't know, how you mean, sorry...
 
Joined
Nov 11, 2013
Messages
5 (0.00/day)
Installed 6.0.9102.1 it on my B450M Aorus M (ALC892) which doesn't have S/PDIF, and though the drivers themselves have been installed, none of the applications installed along detect the sound device:





Installed an older version after uninstalling the most recent ones with DDU on Safe Mode, but still nothing. I read reports of other users who own motherboards with ALC892 codec (such as Asrock B450M Steel Legend) and it worked for them, so I wonder why it isn't for me.
 

c300g97

New Member
Joined
Feb 15, 2021
Messages
1 (0.08/day)
Hi !
I've tried to install the latest version of your driver on my notebook (ALC 255), and although supported i don't get access to any surround application (No one is present, even though i had them selected during installation phase), and Dolby Access simply crashes on startup...
I have done a clean audio driver install, so that's not the issue appearently.
Maybe ALC255 is not supported?

I have the Acer Aspire 5-A515 notebook.
 
Joined
Dec 8, 2020
Messages
199 (2.43/day)

@Metal-Tom


You compare the code in your inf file, and the one you are getting the new code from, then you 'spot the difference' between the two (examples: new code, code removed), and transfer the changes to a text file.
The transfer to a separate text file makes it easier to make an extension .inf, since your extension will be adding to pre-existing drivers, rather than install the full driver.

You will also need any .dll, .sys (so on) files that are used in the .inf file you are getting your new info from.

--

Read over a pre-existing extension .inf, its structure is very similar to an ordinary driver .inf, but with a different class ID and some changes.

====

@ksio89


Go to 'add and remove programs' (apps & features), uninstall all Realtek and AAF (Alan Finotty), then restart. In device manager, check your audio device is 'Microsoft', or no branding audio device.
Open 'command prompt' (or two, one to read) as admin, and type: pnputil -e | Then read the screen, look for Alan Finotty, and Realtek as 'sound device', copy the oemX names.

Now type: pnputil -d oemX.inf | where oemX.inf is like oem22.inf, do this for all then restart. If it fails, right click the device in 'device manager', and uninstall, try again.

pnputil.exe | Microsoft PnP Utility - Tool to add, delete, export, and enumerate driver packages. | STRONTIC

I suggest running a registry cleaner, now install the latest package, and enjoy!
 
Last edited:
Joined
May 20, 2018
Messages
140 (0.14/day)
Location
Germany
System Name Metal-Tom-PC
Processor AMD Ryzen 5 2600x
Motherboard ASUS ROG Crosshair VI Extreme
Cooling Boxed
Memory Mushkin DDR4 16 GB
Video Card(s) ASUS RX560 4GB
Storage 1x M2-SSD @256GB/1x Intenso SATA-SSD @120GB/1x Intenso SATA-SSD @240GB/2x WD10EZRX @1TB/1,5 TB HDD
Display(s) 1x Samsung LE40F86BDX (TV)/1x Samsung SyncMaster T240
Case Thermaltake Kandalf LCS
Audio Device(s) Realtek ALC1220A
Power Supply SeaSonic Focus Plus Gold 80+ 750W
Mouse Logitech M210
Keyboard Logitech K260
Software Win 10 Pro x64 v20H2
@Metal-Tom

You compare the code in your inf file, and the one you are getting the new code from, then you 'spot the difference' between the two (examples: new code, code removed), and transfer the changes to a text file.
The transfer to a separate text file makes it easier to make an extension .inf, since your extension will be adding to pre-existing drivers, rather than install the full driver.

You will also need any .dll, .sys (so on) files that are used in the .inf file you are getting your new info from.

--

Read over a pre-existing extension .inf, its structure is very similar to an ordinary driver .inf, but with a different class ID and some changes.

Could you pls do it once for me? At now, it seems to be some heavy for me, sorry...
 

Lucky8

New Member
Joined
Mar 4, 2019
Messages
2 (0.00/day)
Hi guys any one has the realtek hda driver test utility ? All posted links seems offline
 
Joined
Nov 29, 2004
Messages
588 (0.10/day)
System Name Blue Beast 2.0
Processor AMD Ryzen 9 3900XT
Motherboard Gigabyte X570 AORUS MASTER
Cooling EK EK-AIO 360 D-RGB
Memory G.Skill Trident Z Neo 32 GB (2 x 16 GB) DDR4-3600 CL16
Video Card(s) EVGA RTX 3090 Ultra Gaming Hybrid
Storage Seagate FireCuda 520 500GB NVME, Western Digital SN750 1TB NVME, Western Digital SN850 1TB NVME
Display(s) AOC AG271QG, Dell UltraSharp U2414H
Case Lian Li PC-O11 Dynamic - Black
Audio Device(s) Asus Xonar DGX PCI-E 5.1
Power Supply Corsair HX850i
Mouse Logitech G502 HERO
Keyboard Corsair Strafe MK.2 Cherry MX Silent
Software Windows 10 Pro 64bit
I made a mod for hardcore Dolby lovers Realtek UAD Dolby Mod

- Dolby Home Theater v4
- Dolby Digital Encoder on digital output
- Dolby Digital Plus Home Theater
- Dolby Headphone v2 on headphone output
- Dolby ATMOS for Gaming
Please re-upload this, I am very interested.
 

dhrto

New Member
Joined
Jan 21, 2021
Messages
10 (0.27/day)
This works, but then you can't adjust the equalizer or any other option :oops:
This kind of makes sense, since the DDL or DTS encoder would just take the 'raw' or un-edited signal and encode it. The encoded signal cannot be adjusted until it is decoded again. Adjustments should be made at the decoder side, i.e. the receiver.
 

shutfu

New Member
Joined
Oct 15, 2020
Messages
3 (0.02/day)
i cant get the equalizer in the realtek HDA panel to show up in the latest version, even if i add the feature with the realtek audio device tweak. infact, none of the changes i make in realtek audio device tweak seemt o have any effect
 

Dee_NA

New Member
Joined
Oct 8, 2019
Messages
19 (0.04/day)
I'm tryin to remember... is there an xml file where the channel count is changed from 2 to 5?
 
Joined
Jun 3, 2020
Messages
15 (0.06/day)
Location
USA
System Name Eh
Processor AMD FX-6300 Overclocked to 4.2ghz
Motherboard MSI 760GM-P34(FX) (Shit Motherboard)
Cooling Default Fan
Memory 8GB
Video Card(s) EVGA Geforce GTX 1060 6GB Overclocked
Storage 1TB Western Digital, 500gb Samsung 860 SSD
Display(s) 24" Acer
Case Cyberpower PC mATX
Audio Device(s) Onboard Realtek ALC887 (Using custom driver from the forums)
Power Supply EVGA Bronze 500 watt
Mouse Logitech Daedalus
Keyboard Dell
Software Windows 10 x64
So I havent updated this in a while and decided to tonight. It seems like every time i do update this i have some issue. lmao. So this time after uninstalling and removing all the alan driver files from the driver store I installed the latest DCH version and now I can only pick stereo speaker setup as everything else is grayed out. Also I dont see Atmos installed anywhere....
 
Joined
May 20, 2018
Messages
140 (0.14/day)
Location
Germany
System Name Metal-Tom-PC
Processor AMD Ryzen 5 2600x
Motherboard ASUS ROG Crosshair VI Extreme
Cooling Boxed
Memory Mushkin DDR4 16 GB
Video Card(s) ASUS RX560 4GB
Storage 1x M2-SSD @256GB/1x Intenso SATA-SSD @120GB/1x Intenso SATA-SSD @240GB/2x WD10EZRX @1TB/1,5 TB HDD
Display(s) 1x Samsung LE40F86BDX (TV)/1x Samsung SyncMaster T240
Case Thermaltake Kandalf LCS
Audio Device(s) Realtek ALC1220A
Power Supply SeaSonic Focus Plus Gold 80+ 750W
Mouse Logitech M210
Keyboard Logitech K260
Software Win 10 Pro x64 v20H2
Joined
Dec 29, 2018
Messages
35 (0.04/day)
I just cant make the 7.1 virtual mod to work. I installed the latest version from the AFF github, but 7.1 doenst work as used to work with really older realtek mod drivers and soundblaster xfi 5....
Could someone help me how to solve this? May I'm doing a wrong setup config....
 

ramm81

New Member
Joined
Feb 23, 2021
Messages
3 (0.60/day)
Hello Great job with this Mod.

Can someone help me, I have the following problem: the black audio connector (rear), which are normally the rear cranks, are changed to be side channels with gray, but my motherboard does not have said connector only black (rear) and I cannot achieve any half put it as rear exit can someone help me?
It is an alc1150 chip and everything works perfect only the side and rear channels fail in the order.

For now the images are from the Windows driver, with the mod driver it only appears as the image on the left, the option of the image on the right does not appear.

Captura.PNG
Captura1.PNG
 
Joined
Jun 3, 2020
Messages
15 (0.06/day)
Location
USA
System Name Eh
Processor AMD FX-6300 Overclocked to 4.2ghz
Motherboard MSI 760GM-P34(FX) (Shit Motherboard)
Cooling Default Fan
Memory 8GB
Video Card(s) EVGA Geforce GTX 1060 6GB Overclocked
Storage 1TB Western Digital, 500gb Samsung 860 SSD
Display(s) 24" Acer
Case Cyberpower PC mATX
Audio Device(s) Onboard Realtek ALC887 (Using custom driver from the forums)
Power Supply EVGA Bronze 500 watt
Mouse Logitech Daedalus
Keyboard Dell
Software Windows 10 x64
So I havent updated this in a while and decided to tonight. It seems like every time i do update this i have some issue. lmao. So this time after uninstalling and removing all the alan driver files from the driver store I installed the latest DCH version and now I can only pick stereo speaker setup as everything else is grayed out. Also I dont see Atmos installed anywhere....
i figured it out i just used the audio tweak tool and added some of the settings in it. i even gave myself a few extras. plus this pretty nifty looking console.

audioconsole.png
 
Joined
May 20, 2018
Messages
140 (0.14/day)
Location
Germany
System Name Metal-Tom-PC
Processor AMD Ryzen 5 2600x
Motherboard ASUS ROG Crosshair VI Extreme
Cooling Boxed
Memory Mushkin DDR4 16 GB
Video Card(s) ASUS RX560 4GB
Storage 1x M2-SSD @256GB/1x Intenso SATA-SSD @120GB/1x Intenso SATA-SSD @240GB/2x WD10EZRX @1TB/1,5 TB HDD
Display(s) 1x Samsung LE40F86BDX (TV)/1x Samsung SyncMaster T240
Case Thermaltake Kandalf LCS
Audio Device(s) Realtek ALC1220A
Power Supply SeaSonic Focus Plus Gold 80+ 750W
Mouse Logitech M210
Keyboard Logitech K260
Software Win 10 Pro x64 v20H2
Joined
Oct 25, 2018
Messages
64 (0.07/day)
I just cant make the 7.1 virtual mod to work. I installed the latest version from the AFF github, but 7.1 doenst work as used to work with really older realtek mod drivers and soundblaster xfi 5....
Could someone help me how to solve this? May I'm doing a wrong setup config....
Any time you are asking for help on forum like this remember to include your system specifications particularly the motherboard make and model, the realtek codec version it uses, your operating system and how you will use the audio (analog speakers or spdif optical output, etc)

Since we know nothing about your system its impossible to know what might be the issue. I have an older ALC892 codec board and while I believe it had 7.1 support its only really outputing at 5.1 because I have a 5.1 stereo setup.

***Breaking news! This is unbelievable to me. Asus no longer has a support page for the P9X79 LE or any X79 motherboard that runs Windows 10. Sure they added Win10 support late but its still totally viable. Its viable but its has issues. I guess Asus expects people to just not use it anymore but that seems terribly contradictory for a company that sells itself on quality components that last a long time. I may upgrade but this year to a more gaming focused machine but I still intend to use this a server. If someone found one of these dead or bought it on the cheap all it likely needs is a bios update. No more driver support or bios downloads at all!? WTF Asus? I have been buying them for over twenty years. This is lame and its going to be hard to buy another Asus. I will definitely take suggestions for a better manufacturer to support.

Missing links:


Installed 6.0.9102.1 it on my B450M Aorus M (ALC892) which doesn't have S/PDIF, and though the drivers themselves have been installed, none of the applications installed along detect the sound device:





Installed an older version after uninstalling the most recent ones with DDU on Safe Mode, but still nothing. I read reports of other users who own motherboards with ALC892 codec (such as Asrock B450M Steel Legend) and it worked for them, so I wonder why it isn't for me.

I have the ALC892. I have never gotten the sonic studio to work. Atmos worked but it didn't seem to add anything. Nahaimic may have worked but it was installed unintentionally and seems to draw more resources I would rather having for gaming. Soundblaster will run 720 suite sometimes for a few days but inevitably it figures out something is missing and the KGA config does not work at all for me (not entirely sure how to use it) What i run and has proven reliable for both analog output (headphones) and SPDIF is to install Alan's STANDARD drivers:


When installing I use this sequence. I have tested this many times your experience may be different. When you run installer first question is whether or not to install Intel bus driver I choose NO. Windows configurations I allow everything but remote desktop. I have no idea why anyone would allow a blind link to remote desktop that could be abused easily. I select Realtek APO with DTS/DDLL. You must deselect A-volute, Atmos and other options or it will install all of them. I dont know why they are all set to install by default since youshould probably just use one at a time. Sometimes I choose soundblaster just to use the recon mode as it does help with directional sound and positioning cues in FPS games. Eventually I will buy a creative card but that is not a option now. After rebooting its necessary to config the audio jack alerts and allow simultaneous outputs and input as well as set default communication devices accordingly. In the sound properties I disable all enhancements and choose 5.1 DTS option for the spdif optical output as well as optional frequencies. I also deselect the "allow exclusive control" as it can cause issues switching back and forth or using multiple apps with sound at the same time. Good luck. My system sounds phenomenal. But that took untold hours of trial and error.
 
Last edited:
Top