• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Several crash in different games, (NOT) solved with TDR Level value but...

Joined
Mar 9, 2016
Messages
62 (0.04/day)
Location
Frankfurt am Main
System Name CaccAMD
Processor Ryzen 3600
Motherboard MSI B450M Mortar MAX
Cooling EK Fluid Gaming A240
Memory HyperX Fury RGB 16GB(8x2) 3200MHz
Video Card(s) Asus RTX 2060 ROG Strix Gaming OC 6GB
Storage Samsung 960 Evo 500GB
Display(s) AOC G2460Fq
Case Phanteks Enthoo Evolv MATX
Power Supply Corsair RMx 550
Mouse Razer Basilisk
Keyboard Razer Blackwindows Tournament Edition Chroma Stealth
Software Win 10 64bit
Hi,
I share my problem and the workaround but I would to like have some answer and help.

My build:
Motherboard: MSI Mortar MAX bios v25
CPU: AMD Ryzen 3600
RAM: 16GB (2x 8192MB) ADATA XPG Spectrix D80 32000
VGA: ASUS GeForce RTX 2060 ROG Strix Gaming OC 6GB
PSU: Corsair Rmx 550
Cooler: EK Fluid Gaming A240
Case: Phanteks enthoo evolv matx
SO: Windows 10 v 1909
Nvidia driver: 441.41
AMD driver: 1.11.22.454

My problem:
Several crash in different games (Call of Duty WWII, Destiny 2, Wolrd of Warships, Rocket League). After a variable time (30 second or 40 minutes) the game crash, it stops to work and the PC come back to the desktop.

- For Destiny 2 the error was ‘’broccoli error’’→ driver video card problem.
- For Call of Duty WWII the error was: ‘’DXGI_ERROR_DEVICE_REMOVED → hardware problem.
- Rocket League and Wolrd of Warships just crash without error → The Windows registry showed: ‘’Live kernel event 141’’

Actions taken to resolve the issues:
To summarize and I write not necessarily in order: reinstalled Windows, updated Windows, reinstalled the Nvidia video card driver (only driver) ,reinstalled the AMD chipset driver, uninstalled not necessary drivers and softwares. I tried different Nvidia driver. I tried 4 different vga (all Nvidia gpu). I tried without AMD chispet driver.

I have done some stress test to check my hardware:
- HCI Memtest, after 10 hours no error found.
- AIDA 64, after 10 hours no error found.
- Prime 95, after 10 hours no error found.
- Futurmark, after 4 hours no error found.
So after spending several days, the problem has not been solved. Don't forget that I tried 4 different video cards to exclude a hardware problem and the stress test for the others component has been negative.

Workaround
Create a new registry key in Windows (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers)→ TdrLevel = 3 (other values didn't work for me).

I am not an expert, the subject here is the ‘’Timeout Detection and Recovery, this is a feature of the Windows operating system which detects response problems from a graphics card, and recovers to a functional desktop by resetting the card.”


Questions:
1)I would to like to know, Is the TDR level related a defective hardware? If yes, in my problem what is the ‘’main defendant’’?
2)This registry key, have some negative impact on the vga performance? For example a low FPS.
3)If it is a driver problem, why still in the end 2019 there are problem like this? Please, Microsoft/AMD/Nvidia/MSI/Asus, can you do something?


Thanks for the assistance and help.

I have an important update: my problem is not resolved and games crash again. This is the error when i try to playing at Cod WWII:
cod error.jpg

Until yesterday night i was sure that the issue was resolved because i played 2 hours without problem. Obviously I was wrong.



Now i tried to set the TdrDelay to 8 but the problem is not resolved :(.

Please, help me. Thanks in advanced.
 
Joined
Nov 25, 2019
Messages
29 (0.31/day)
Location
Taiwan
Processor i5-9600K
Motherboard Gigabyte Z390 Gaming X
Memory Micron Ballistix Sports LT 3000 8G*4
Video Card(s) MSI 2070 Ventus
Storage Adata SX6000 Pro 512G
Display(s) Acer ED323QUR A
Case Phanteks Eclipse P350X
Power Supply Super Flower Leadex Gold 650W
Mouse Razer Basilisk Essensial
Keyboard i-rocks K65M
Maybe try lowering the GPU core clock?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,679 (6.42/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Perhaps you should grab a 5500XT or 5700 and get rid of that potato card you have
 
Joined
Sep 27, 2019
Messages
201 (1.31/day)
Location
Canada
System Name New compy
Processor AMD Ryzen 3600x
Motherboard MSI MEG x570 ACE
Cooling Noctua NH-D15S w. FHP141 + Xigmatek AOS
Memory Patriot Viper 16gb ddr4400
Video Card(s) Asus GTX 1070 HB SLI
Storage 9.5tb
Display(s) Alienware AW2518H 24" 240hz
Case Thermaltake Core v71
Audio Device(s) iFi Nano Idsd Le, Creative T20 + T50, Sennheiser HD6Mix
Power Supply EVGA Supernova G2 1000w
Mouse Logitech G502 Hero custom w. G900 scroll wheel mod
Keyboard Corsair K68 RGB + K70 RGB
Software Win 10 Pro
Benchmark Scores https://valid.x86.fr/83f50d

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,679 (6.42/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Mar 15, 2013
Messages
3,062 (1.21/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10
Joined
Mar 9, 2016
Messages
62 (0.04/day)
Location
Frankfurt am Main
System Name CaccAMD
Processor Ryzen 3600
Motherboard MSI B450M Mortar MAX
Cooling EK Fluid Gaming A240
Memory HyperX Fury RGB 16GB(8x2) 3200MHz
Video Card(s) Asus RTX 2060 ROG Strix Gaming OC 6GB
Storage Samsung 960 Evo 500GB
Display(s) AOC G2460Fq
Case Phanteks Enthoo Evolv MATX
Power Supply Corsair RMx 550
Mouse Razer Basilisk
Keyboard Razer Blackwindows Tournament Edition Chroma Stealth
Software Win 10 64bit
Maybe try lowering the GPU core clock?
I tried and it didn't work. Thanks for the suggestion.

Perhaps you should grab a 5500XT or 5700 and get rid of that potato card you have
Lol, this is a great suggestion. Thanks...but maybe i should grab an Intel platform :laugh:.

Looks like gpu issue or gpu driver issue, download this driver and test.

I tried and it didn't work. Thanks for the suggestion.


I tried the dch version (standard is not compatible) and it didn't work. Thanks for the suggestion. I tried also with another oldest version but i have the same negative result.

I tried to put the DDR modules in the other 2 slots but again negative result.

As i wrote, i tested with different vga:
- The first one was an 1660 Ti (second market) and the problem was the same so i thought that the problem was a defected vga.
- Second one was a 2060 (from a store but reconditioned). With this VGA the problem was worst, no monitor signal. I thought , i am not lucky, another defected VGA.
- The third video card was an old vga, GTX 210 ( i have this card only for emergency and test use). With this VGA the problem was the lost video signal but only for few seconds and with a random time. I thought, maybe this vga is too old to work properly in this news system.

So, 4 VGA tested and i think the problem it is not the VGA.

Do you have other idea/suggestion? thanks again in advance for your advice guys:toast:
 
Joined
Mar 15, 2013
Messages
3,062 (1.21/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10

 
Joined
Dec 18, 2012
Messages
338 (0.13/day)
Processor Core I7-2600k @4,9GHZ @1,4V
Motherboard Asus p8-Z68 V Gen3
Cooling 2x1080 Custom loop
Memory G.Skill Ripjaws x 16gb 1866 cl9
Video Card(s) EVGA 1080 Ti
Storage Raid 0 2 x Sasmsung 850 EVo
Display(s) ASUS Swift
Case Test Bench
Power Supply Be quiet! 850 P10
Mouse G5
Keyboard Old USB Dell Keyboard
Software Windows 10
The last time i had the DXGI_ERROR_DEVICE_REMOVED it was my psu going bad.
The last time i had LiveKerenelEvent 141 it was my psu going bad.
Now i am not saying YOUR Psu is going bad, but if you have the chance try another one.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,679 (6.42/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
The last time i had the DXGI_ERROR_DEVICE_REMOVED it was my psu going bad.
The last time i had LiveKerenelEvent 141 it was my psu going bad.
Now i am not saying YOUR Psu is going bad, but if you have the chance try another one.
You mean 41

I tried and it didn't work. Thanks for the suggestion.



Lol, this is a great suggestion. Thanks...but maybe i should grab an Intel platform :laugh:.



I tried and it didn't work. Thanks for the suggestion.




I tried the dch version (standard is not compatible) and it didn't work. Thanks for the suggestion. I tried also with another oldest version but i have the same negative result.

I tried to put the DDR modules in the other 2 slots but again negative result.

As i wrote, i tested with different vga:
- The first one was an 1660 Ti (second market) and the problem was the same so i thought that the problem was a defected vga.
- Second one was a 2060 (from a store but reconditioned). With this VGA the problem was worst, no monitor signal. I thought , i am not lucky, another defected VGA.
- The third video card was an old vga, GTX 210 ( i have this card only for emergency and test use). With this VGA the problem was the lost video signal but only for few seconds and with a random time. I thought, maybe this vga is too old to work properly in this news system.

So, 4 VGA tested and i think the problem it is not the VGA.

Do you have other idea/suggestion? thanks again in advance for your advice guys:toast:
Probably bad house power or power supply.
 
Joined
Mar 15, 2013
Messages
3,062 (1.21/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10
since a lot has been tested with few different vgas, drivers and win installs at this point i'd start ruling out other components one by one.
starting with psu and ram as most easy replaceable parts
 
Joined
Mar 9, 2016
Messages
62 (0.04/day)
Location
Frankfurt am Main
System Name CaccAMD
Processor Ryzen 3600
Motherboard MSI B450M Mortar MAX
Cooling EK Fluid Gaming A240
Memory HyperX Fury RGB 16GB(8x2) 3200MHz
Video Card(s) Asus RTX 2060 ROG Strix Gaming OC 6GB
Storage Samsung 960 Evo 500GB
Display(s) AOC G2460Fq
Case Phanteks Enthoo Evolv MATX
Power Supply Corsair RMx 550
Mouse Razer Basilisk
Keyboard Razer Blackwindows Tournament Edition Chroma Stealth
Software Win 10 64bit
since a lot has been tested with few different vgas, drivers and win installs at this point i'd start ruling out other components one by one.
starting with psu and ram as most easy replaceable parts
yes, I'm doing just that, especially the ram modules.
 
Joined
Mar 15, 2013
Messages
3,062 (1.21/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10
with all different vgas did you used pcie16 slot for testing or you tried with other pcie slot too.
because one possible cause of the problem could be faulty pcie slot. so you may try with 2nd slot before you try with different mobo.
 
Joined
Mar 9, 2016
Messages
62 (0.04/day)
Location
Frankfurt am Main
System Name CaccAMD
Processor Ryzen 3600
Motherboard MSI B450M Mortar MAX
Cooling EK Fluid Gaming A240
Memory HyperX Fury RGB 16GB(8x2) 3200MHz
Video Card(s) Asus RTX 2060 ROG Strix Gaming OC 6GB
Storage Samsung 960 Evo 500GB
Display(s) AOC G2460Fq
Case Phanteks Enthoo Evolv MATX
Power Supply Corsair RMx 550
Mouse Razer Basilisk
Keyboard Razer Blackwindows Tournament Edition Chroma Stealth
Software Win 10 64bit
i think that maybe the problem is one module of DDR. I'm still testing to be sure. Tomorrow i will test also with different DDR modules.
 
Joined
Mar 15, 2013
Messages
3,062 (1.21/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10
shitty problem. i hope you solve it sooner rather then later.
 
Joined
Mar 9, 2016
Messages
62 (0.04/day)
Location
Frankfurt am Main
System Name CaccAMD
Processor Ryzen 3600
Motherboard MSI B450M Mortar MAX
Cooling EK Fluid Gaming A240
Memory HyperX Fury RGB 16GB(8x2) 3200MHz
Video Card(s) Asus RTX 2060 ROG Strix Gaming OC 6GB
Storage Samsung 960 Evo 500GB
Display(s) AOC G2460Fq
Case Phanteks Enthoo Evolv MATX
Power Supply Corsair RMx 550
Mouse Razer Basilisk
Keyboard Razer Blackwindows Tournament Edition Chroma Stealth
Software Win 10 64bit
So, i tested one module at a time and with one module games crashed, with the other one module all was good. Now i have a new couple of memory and all works very good. So was a bad memory module and the cause of the crash was this. Thanks anyway for your help. :toast:
 
Top