Tuesday, April 7th 2020

AMD Posts Updated Chipset Drivers that Fix Installer Bugs and Stability Issues

AMD late Tuesday posted updated versions of its Chipset Software for AMD "Promontory" 300-series, 400-series, and homebrew X570 chipsets. The new version 2.04.04.111 drivers now come with a brand new installer interface carried over from Radeon Software Adrenalin 2020. AMD has cleaned up several deprecated device IDs from the IOV and integrated USB 3.0 controller drivers. The company also mentions "general system stability improvements" without specifying what these are.

Thanks to the new installer, the drivers no longer run into the "Error 1720" code during installation. A bug that caused the drivers to not install to a non C-drive location has been fixed. A screen rotation bug with certain mobile AMD processors has been fixed. Also fixed is a rare system halt bug with certain 7th gen A-series (socket AM4) processors. Grab the drivers from the link below.

DOWNLOAD: AMD Chipset Software
The change-log follows.

Release Highlights
  • Removed deprecated device IDs from the IOV driver
  • Removed deprecated device IDs from the USB 3.0 driver
  • General system stability improvements
Fixed Issues
  • Installer may hang during installation progress
  • Installer may abort with "Error 1720" code
  • Installation will not install on a non C:\ location
  • Resolved screen rotation bug with select AMD mobile processors
  • Rare system halt on 7th Gen AMD A-Series APUs
Known Issues
  • Windows Installer pop up message may appear during install
  • Moving installer window during install process may cause installer window to flicker/move around the screen
  • Cannot open installation log file after completion
  • Installer may not update a sub-package to the latest version
    o Workaround: Manually uninstall any prior sub-package, reboot, then re-install the full Chipset package
Add your own comment

15 Comments on AMD Posts Updated Chipset Drivers that Fix Installer Bugs and Stability Issues

#1
Cheeseball
Not a Potato
  • Installation will not install on a non C:\ location
  • Resolved screen rotation bug with select AMD mobile processors
They finally fixed these two issues as I can confirm its working on a Flex 14 with the 3700U.
Posted on Reply
#3
sprcorreia
Just tried to download, it's a corrupted .zip file.
Posted on Reply
#4
Gmr_Chick
Oh nice! I tried installing the X570 chipset a couple weeks ago and kept getting an error. Come to find out it wasn't just me, but many, many others had the same problem.

Nice to see they fixed it. Kudos AMD :clap:
Posted on Reply
#5
sutyi
yeeeeman
Installer bugs??? :roll:
Something is borked at some users with Windows Installer going wonky and they had the installer effectively not installing anything.
It supposedly got fixed in this release.

Also we know have release notes for the Chipset drivers. Wahey!
Posted on Reply
#6
ARF
Installed it. Works normally.
Posted on Reply
#8
PerfectWave
installed fine but the installer window bar remain at 0% LOL i saw driver were installed on device manager. After almost a month they fixed it damn AMD
Posted on Reply
#9
gamefoo21
Does it spell 'boost' properly this time?
Posted on Reply
#10
0x4452
I installed it and now the idle CPU frequency never falls below 3.6 GHz and CPU cores never park, which is likely how they gain the little bit of performance. What a "fix"...
Posted on Reply
#11
Caring1
I installed last night, and not an issue in sight.
Everything is running perfectly as it should.
Posted on Reply
#12
RealNeil
I got the file for when I build my 3800X box. Thanks for the link!
Posted on Reply
#13
Yurie
im trying to update right now and.. it fails..
Posted on Reply
#14
gamefoo21
Yurie
im trying to update right now and.. it fails..
You have to uninstall the old drivers first if this happens. Uninstall then reboot then install.
Posted on Reply
#15
DarthFK
Well, I get error codes 8 and 04 on a brand new Asus C6H WiFi, post fresh Win10 install, as soon as I do a restart after chipset driver install. Same for Adrenaline for the GPU. The system just hangs upon restart and I get those error codes. So, drivers bugs are not solved. This becomes a really annoying AMD problem, drivers.
Posted on Reply
Add your own comment