Thursday, December 11th 2008

RivaTuner Version 2.21 Released, Fixes GTA4 Missing Textures

RivaTuner, a very powerful and easy to use video card tweaking utility, was updated today to version 2.21. This release has a small number of updates yet mainly is a hotfix for Grand Theft Auto 4 missing texture issue for some GeForce owners in combo with this tool. NVIDIA GeForce drivers 180.60, 180.70 and 180.84 as well as AMD/ATI Catalyst 8.12 are also supported now. For detailed information, please check out the changelist below.

DOWNLOAD: RivaTuner Version 2.21

Version 2.21:

Minor bugfixes:
  • FOURCC INTZ and RAWZ formats are no longer forcibly disabled on GeForce 6 and newer display adapters when closing the 'Textures' tab in Direct3D tweaks dialog. Please take a note that these formats are required for proper GTA IV functionality, so if you experience problems with missing textures in this game on NVIDIA GeForce 6 and newer display adapters then please try to open the 'Textures' tab and press the 'Defaults' button.
  • Fixed 'Restore after suspended mode' option in low-level fan control tab, corrupted in the previous release due to multi-GPU related core changes.
What's new:
  • Updated databases for Detonator and ForceWare drivers. Added databases for ForceWare 180.60, 180.70 and 180.84.
  • Added Catalyst 8.12 driver family detection.
  • Added 'Enable FOURCC INTZ surfaces' and 'Enable FOURCC RAWZ surfaces' options to the 'Textures' tab of the Direct3D tweaks dialog.
  • 'Restore after suspended mode' option in low-level fan control tab is multi-GPU oriented now. Now the option affects all display adapters in the system instead of currently selected display adapter only.
  • 'Allow separate 2D/3D clock frequency adjustment' option is no longer provided when enabling driver-level hardware overclocking. The option is now hidden to reduce the amount of false bugreports posted by the beginners trying to disable 2D/3D clock frequncy then claiming that the hardware stays at extremely low boot clocks. Power users can still control this option via AllowMaxPerf registry entry.
  • Extended list of detectable supported FOURCC formats in 'IDirect3D9 HAL adapter formats' diagnostic report category.
Source: Guru3D
Add your own comment

12 Comments on RivaTuner Version 2.21 Released, Fixes GTA4 Missing Textures

#1
lemonadesoda
That's interesting. So some of the problems peeps have had with GTA4 (like missing textures, and maybe other issues) were partly due to having Rivatuner installed (and modifying default operation of the drivers).

Well done for whoever caught that one! GJ to rivatuner for fixing it quick. Unlucky to all those who have been chasing mysterious bugs!
Posted on Reply
#2
mdm-adph
I've heard they had some major problems with GTA4 on the PC -- are those mostly cleared up? Was really wanting to buy it. :D
Posted on Reply
#3
V's effex
Download link has expired...

Edit: nvm it works now...

thanks downloading now...
Posted on Reply
#4
ucanmandaa
Weird game GTA4 is, when I set it to high textures (-norestrictions) it runs better with nearly no missing textures even its warns about not enough resources bla bla bla...
Posted on Reply
#5
TheGuruStud
mdm-adph said:
I've heard they had some major problems with GTA4 on the PC -- are those mostly cleared up? Was really wanting to buy it. :D
I'll save you the money. You can't play it.

Nothing can play this outside of the newest generation.

and before anyone wants to be a smart ass, 800x600 with low details doesn't count.

I had everything on medium (1280x1024) and got about 15 fps tops (using 180.84s). It's a worthless port and rockstar needs to be sued.
Posted on Reply
#6
ucanmandaa
It is very cpu dependent, it is either a crappy port or really hard on cpu all I know is it plays on quads better.
Posted on Reply
#7
newtekie1
Semi-Retired Folder
TheGuruStud said:
I'll save you the money. You can't play it.

Nothing can play this outside of the newest generation.

and before anyone wants to be a smart ass, 800x600 with low details doesn't count.

I had everything on medium (1280x1024) and got about 15 fps tops (using 180.84s). It's a worthless port and rockstar needs to be sued.
It plays fine on my Athlon X2@2.8GHz(Socket 939), 2GB of DDR, HD4670 512MB. This is at 1280x1024, medium settings textures and render detail, shadows set at 1, vehicle density and view distance set to 25. The game is pretty smooth at these settings and looks a hell of a lot better than the console versions. It helps if you turn off the clip recording feature, it really takes load of the CPU.
Posted on Reply
#8
TheGuruStud
newtekie1 said:
It plays fine on my Athlon X2@2.8GHz(Socket 939), 2GB of DDR, HD4670 512MB. This is at 1280x1024, medium settings textures and render detail, shadows set at 1, vehicle density and view distance set to 25. The game is pretty smooth at these settings and looks a hell of a lot better than the console versions. It helps if you turn off the clip recording feature, it really takes load of the CPU.
And that's hardly medium if the sliders are set to low. Just saying.
Posted on Reply
#9
Hayder_Master
sorry riva tuner fix games problem , mmm that's cool
Posted on Reply
#10
newtekie1
Semi-Retired Folder
TheGuruStud said:
And that's hardly medium if the sliders are set to low. Just saying.
They aren't set to low, there is no "low" with sliders. I've actually turned shadows completely off, as they were not even in the original console versions. Draw distance and vehicle density was only 21 on the consoles, so 25 is higher than that.

I don't really care that it can't max out the settings, or set it to what some would consider high, as the game already looks amazing on these settings, and plays perfectly. It looks better than the console, at a higher resolutions, I can't complain.

"Low" and "high" settings is just a label, if Rockstar had made the settings I use "High" and locked off the ability to make the game look any better, then you probably wouldn't be complaining right now and most others probably wouldn't either. As the game would run on mid-range hardware, at all "high" settings with issue, and look good.
Posted on Reply
#11
BrankoJ
I have ATI 3850 512 mb, @ gb RAM, C2D 7200@3.36Ghz, WinXP, and with AUTO setting the game (1680x1050, Med.Text, High Render...) has missing textures. Cat 8.12 got it to work in 1280x800 but some time they appear. Also I have RT 2.08. Do I have to Enable this thing or are ATI owner unafected by this RT bug?
Posted on Reply
#12
Luke
It solved my problem I have textures in GTA4 now yay
Posted on Reply
Add your own comment