Tuesday, May 23rd 2017

TechPowerUp GPU-Z 2.1.0 Released

TechPowerUp today released GPU-Z 2.1.0, a major update to the popular graphics subsystem information and diagnostic utility. Version 2.1.0 introduces the new Advanced tab, which gives you in-depth information related to your installed graphics hardware and software related to graphics and GPU compute, such as API-level features available to you. Information is presented as drop-down lists in the new Advanced tab. API features of DirectX, OpenCL, CUDA, and Vulkan are added.

In addition to the groundbreaking Advanced tab, GPU-Z 2.1.0 adds support for EVGA iCX technology, and can put out live sensor data from various parts of your EVGA iCX graphics card. There's also the usual addition of new GPU support, which now includes NVIDIA Tesla P100 PCIe, Tesla M10, Quadro P5000, Intel HD Graphics 615, and AMD Radeon HD 8350G. In addition, there are various user-interface bug fixes and improvements.

DOWNLOAD: TechPowerUp GPU-Z 2.1.0
The change-log follows.

  • Advanced Tab added, with additional on info on VGA BIOS, CUDA, OpenCL, DirectX, Vulkan
  • Added support for EVGA iCX Sensors
  • Fixed BIOS saving on GeForce 900 Series and newer, on 32-bit OS
  • NVIDIA PerfCap Reason "Util" renamed to "Idle"
  • Added retry option to "Rendering doesn't work over remote desktop" message
  • When log file can't be written to, stop trying until re-enabled by user
  • Fixed DirectX Support detection on old ATI cards (R600 and older)
  • Added support for NVIDIA Tesla P100 PCIe, Tesla M10, Quadro P5000
  • Added support for Intel Graphics 615
  • Added support for AMD HD 8350G
Add your own comment

52 Comments on TechPowerUp GPU-Z 2.1.0 Released

#1
shhnedo
FIRST!
Nice job on the new update!
Posted on Reply
#2
Nuckles56
shhnedo said:
FIRST!
Nice job on the new update!
This isn't Youtube you know
Posted on Reply
#3
okidna
It's crashing on my old PC (FX6300, GTX970) :


Tried to use installed version and standalone version, both are crashing.
It's even worse for the ROG version :



EDIT : temporarily disabling Kaspersky Internet Security does not help, still crashing.
Posted on Reply
#4
W1zzard
okidna said:
It's crashing on my old PC (FX6300, GTX970) :


Tried to use installed version and standalone version, both are crashing.
It's even worse for the ROG version :



EDIT : temporarily disabling Kaspersky Internet Security does not help, still crashing.
Looking into both
Posted on Reply
#5
shhnedo
Nuckles56 said:
This isn't Youtube you know
Don't worry, I'm aware.

Selecting NVDIA BIOS in Advanced gives me this:


Here's some info:
Posted on Reply
#6
WaroDaBeast
Working fine here. I'm using Windows 7 SP1 x64.
Posted on Reply
#7
W1zzard
Anyone who gets the crash in the regular version -> please send me a PM so this can be fixed
Posted on Reply
#8
W1zzard
ROG version has been updated and should work now (just download the same file)
Posted on Reply
#9
9700 Pro
Works perfectly fine, W10Pro w/ latest updates & GTX970 w/ 381.89 drivers. :)
Posted on Reply
#10
BadIronTree


First Time that it crashed :p
I have x99 mobo with 6800k and a 7970 AMD

Posted on Reply
#11
W1zzard
BadIronTree said:


First Time that it crashed :p
I have x99 mobo with 6800k and a 7970 AMD


thanks for your help! crash on AMD cards should be fixed now, please redownload from the official 2.0.0 download
Posted on Reply
#12
DRDNA


Same here GTX 960M driver 368.39....PM sent....also 3 crash reports submitted.

EDIT the last version worked great on this rig.
Posted on Reply
#13
JalleR
Is it a bug or a feature that it is not passable to read the speed, mem, etc. in shared memory anymore??

I was using that for my screen on logitech G19 keyboard. worked fine in V1.20
Posted on Reply
#14
W1zzard
okidna said:
It's crashing on my old PC (FX6300, GTX970) :.
Thanks a lot for your help. This has been fixed now.

Please redownload from the official download page
Posted on Reply
#15
W1zzard
JalleR said:
Is it a bug or a feature that it is not passable to read the speed, mem, etc. in shared memory anymore??

I was using that for my screen on logitech G19 keyboard. worked fine in V1.20
shmem should be unchanged. does it not work at all? or only certain values missing?
Posted on Reply
#16
9700 Pro
Am I the only who doesn't have any problems? Works as fine as the previous version.
Posted on Reply
#17
okidna
W1zzard said:
Thanks a lot for your help. This has been fixed now.

Please redownload from the official download page
You're welcome, glad I can help.

My GPU-Z debug build collection :roll: :



I have to say that @W1zzard dedication to make sure GPU-Z works for all users is AMAZING. Kudos to you good sir! :toast:
Posted on Reply
#18
JalleR
W1zzard said:
shmem should be unchanged. does it not work at all? or only certain values missing?
All is missing
Posted on Reply
#19
W1zzard
2.1.0 released with many bugfixes
Posted on Reply
#20
W1zzard
JalleR said:
All is missing
Please download 2.1.0, should be fixed
Posted on Reply
#21
JalleR
You need to update the Title info :D


Posted on Reply
#22
DRDNA
W1zzard said:
Please download 2.1.0, should be fixed
The latest download for 2.1.0 installs its self as 2.0.0 even after uninstalling the 2.0.0 and downloading 2.1.0 it installs as 2.0.0 and says that 2.1.0 is available for download.
Posted on Reply
#24
W1zzard
DRDNA said:
The latest download for 2.1.0 installs its self as 2.0.0 even after uninstalling the 2.0.0 and downloading 2.1.0 it installs as 2.0.0 and says that 2.1.0 is available for download.
Fixed. Please redownload 2.1.0. Thanks again
Posted on Reply
#25
JalleR
All is working again here :) gj..
Posted on Reply
Add your own comment